[ eclipse ] Cannot change version of project facet Dynamic Web Module to 2.5 , 프로젝트의 java 버젼, Dynamic Web Module 버젼 변경시 오류 > editor

본문 바로가기
사이트 내 전체검색

editor

[ eclipse ] Cannot change version of project facet Dynamic Web Module to 2.5 , 프로젝트의 java 버젼, Dynamic Web Module 버젼 변경시 오류

페이지 정보

작성자 웹지기 댓글 0건 조회 1,968회 작성일 22-12-26 15:02

본문

 이클립스에서 이것 저것 테스트를 해보다가 

프로젝트에서 마우스 우클릭 > Properties > Project Facets 에서 Dynamic Web Module 4.0 // Java 1.8 로 올려서 저장을 한다음
처음에 셋이팅이 되었던 DYnamic Web Module 2.5 // Java 1.7 로 변경하려니 오류가 발생 

Cannot change version of project facet Dynamic Web Module to 2.5

프로젝트의 java 버젼, Dynamic Web Module 버젼 변경시 오류

 

강제로  변경을 위해 xml 파일을 찾아서 변경을 했다.

/workspace.edu  > 프로젝트 폴더 > .settings > org.eclipse.wst.common.project.facet.core.xml 파일을 vscode나 여타 편집기로 열어서

jst.java 버젼 1.7

jst.web 버젼 2.5 

수정후 저장 하고 해보니  된다.

추천0 비추천0

댓글목록

등록된 댓글이 없습니다.

Total 53건 1 페이지
  • 53 [ eclipse ] 이클립스 검색 후 항상 새창에서 소스 파일 열기
  • [ eclipse ] 이클립스 검색 후 항상 새창에서 소스 파일 열기 - 계속 같은 창에서 소스 파일이 열려서 검색을 하게 되었다. 윈도우에서는 window > preferences > 맥에서는 eclipse > settings > General > Search 메뉴 또는 type filter text 창에 search 2번의 Reuse editors to show matches 를 체크 해제 하면 중복되어서 뜨지 ...
  • 웹지기 02-24 2009 0 0 댓글 0
+5
  • 52 [ eclipse ] 맥에서 lombok 설치하기
  • lombok 사이에서 다운로드 받기 롬복 사이트에서 download 로 이동한다. https://projectlombok.org/download 다운로드를 받아서 실행을 시킨다. lombok.jar 파일을 클릭해서 실행을 시키면 다음과 같은 화면이 뜬다 그리고 Cat't find IDE가 뜰 경우가 있고 안뜨는 경우가 있는데 뜰경우 OK를 눌러 창을 닫는다. IDEs 의 창에 아무것도 뜨지 않으면 선택해서 연결을 해줘야 한다. 이런경우 Specify locatio...
  • 웹지기 02-17 1956 0 0 댓글 0
  • 51 [ eclipse ] 브라우져 외부에서 실행하기 및 브라우저 정하기
  • 프로젝트를 실행하면 내부 브라우져에서 실행되게 설정이 되어있다. 외부에서 볼 수 있게 연결 수정을 해보자. 설정창을 띄운다.Preferences >> 맥에서는 Settings >> Preferences >> General >> Web Browser >> Use internal web browser ( 내부에서 실행 ) Preferences ...
  • 웹지기 02-17 2115 0 0 댓글 0
  • 열람중 [ eclipse ] Cannot change version of project facet Dynamic W…
  • 이클립스에서 이것 저것 테스트를 해보다가 프로젝트에서 마우스 우클릭 > Properties > Project Facets 에서 Dynamic Web Module 4.0 // Java 1.8 로 올려서 저장을 한다음처음에 셋이팅이 되었던 DYnamic Web Module 2.5 // Java 1.7 로 변경하려니 오류가 발생 Cannot change version of project facet Dynamic Web Module to 2.5 프로젝트의 java 버젼,...
  • 웹지기 12-26 1969 0 0 댓글 0
  • 49 [ IntelliJ ] MacOS - 단축키 정리
  • command(⌘) = Cmd option(⌥) = Alt control(⌃) = Ctrl ------------------------------------------------------------------------------------------------ cmd(⌘) + N : 현재위치를 기준으로 디렉토리, 패키지 및 생성목록을 보여주는 것 이외에도 생성자/ getter/setter도 보여준다. cmd(⌘) + P : 해당 클래스가 인스턴스를 생성하기 위해 필요한 인자 값을 ...
  • 웹지기 10-21 2667 0 0 댓글 0
  • 47 [ eclipse ] 맥OS (MacOS) 에서 자동완성 단축키를 변경
  • 맥OS (MacOS) 에서 자동완성 단축키가 한/영 전환키와 맞물려 있어서 단축키가 먹지 않아서 변경을 해보자 Preferences > 검색창에 keys > type filter text 창에 Content Assist > Binding 에 ^Space 클릭 > ⌃⌘Space 로 변경 후 apply and close
  • 웹지기 07-27 2234 0 0 댓글 0
+1
  • 46 [ intelliJ ] 맥에서 인텔리제이 mariadb jar 설치 및 jdbc 연결 설정
  • [ intelliJ ] 인텔리제이에 mariadb jar 설치 및 jdbc 연결 설정 일단https://mariadb.com/downloads/ 로 이동해서 connects 탭을 클릭한다. product -> Java 8 + connector 선택 version 은 최신버젼으로 해서 다운로드를 클랙했다. jar 파일이 다운로드가 된다. 이제 intelliJ 로 이동해서 File > Project Structure > Libraries...
  • 웹지기 07-13 2907 0 0 댓글 0
  • 45 [ intelliJ ] 맥용 단축키 (preferences > keymap > editor actions …
  • intelliJ 맥용 단축키 (preferences > keymap > editor actions 부분 macOS) 정렬 Option + Command + l 커서 이동 Command + 방향키( <- , ->) 라인맨 왼쪽, 라인맨 오른쪽또는 Fn + 방향키( <- , ->)복사 Command + c붙여넣기 Command + v블럭씌우기 Command + Shift + 방향키(<...
  • 웹지기 07-12 2162 0 0 댓글 0
  • 44 [ phpstorm ] 자동 줄바꿈( 개행 )
  • Preferences - mac -> Cmd+, - window,linux -> Setting(Ctrl+Alt+s) editer > general - soft-wrap these files 에 원하는 파일 추가 (*.md; *.txt; *.rst; *.adoc; *.php, *.html; *.css; *.js; *.htm; *.php3)
  • 웹지기 07-07 3082 0 0 댓글 0
  • 43 [ phpstorm ] 화면에 세로줄 없애기
  • Preferences - mac -> Cmd+, - window,linux -> Setting(Ctrl+Alt+s) editer > general > apperance - show hard wrap and visual guides 체크해제. 저장 하면 사라짐.
  • 웹지기 07-07 2172 0 0 댓글 0
+6
  • 42 [ phpstorm ] 윈도우에서 파일 자동 배포( deployment use rsync for downlo…
  • Tools>Deployment>Configuration>Usersyncfordownload/upload이부분에 체크를 해서 자동 저장을 하고 싶다면rsync와openssl을 설치해야한단다. Rsync라는게macos와linux에서는자동으로 지원이 되어서 찾아서 연결만 해주면 되지만 윈도우 같은 경우 설치가 되어있지 않다. 검색을 해보니 약간 복잡 해야 할 일이 있지만 ...
  • 웹지기 06-13 2422 0 0 댓글 0
  • 40 [ vscode ] vscode에서 php 사용하기
  • vscode에서 php 사용하기위해서 설치할 것은 Extenstions > 검색창에 > PHP IntelliSense >> install >> manage >> Extension settings > Edit in settings.json >> 아래부분을 추가 "php.executablePath": "p...
  • 웹지기 05-04 5976 0 0 댓글 0
  • 39 [ 정부 표준 프레임워크 ] eGovFrameDev DB 접속오류 해결
  • 정부 프레임워크 이클립스 DB접속 오류 Plug-in org.eclipse.datatools.sqltools.result.ui was unable to load class org.eclipse.datatools.sqltools.result.internal.ui.view.ResultsView. 이러한 오류가 발생할 때 C:\eGovFrame-3.9.0\workspace.edu\.metadata\.plugins\org.eclipse.datatools.sqltools.result...
  • 웹지기 03-03 4226 0 0 댓글 0
게시물 검색

회원로그인

접속자집계

오늘
2,684
어제
4,866
최대
33,828
전체
9,209,621

그누보드5
Copyright © www.funyphp.com. All rights reserved.